How To Fix
Trending

This Build of Vanguard Requires TPM Version 2.0

Fix Valorant TPM 2.0 and Secure boot Error in Windows 11

We all love to play Valorant and why not?? It gives thrill along with the excitement in gaming that no other game  can match. However with the launch of Windows 11 by Microsoft, Riot Games makes TPM 2.0 and secure boot a necessary requirement to play Valorant failing which gives you the error “This build of Vanguard Requires TPM Version 2.0 and Secure boot to be enabled in order to play”

Here is a direct video to fix “This build of Valorant requires TPM version 2.0 and secure boot to be enabled”

Now that’s all about the small description regarding the Riot games and Microsoft requirement about Windows 11 and Valorant. Now let’s proceed with the steps fix Valorant error “This build of Vanguard Requires TPM Version 2.0 and Secure boot to be enabled in order to play” so that you can easily play Valorant in Windows 11 without any problems.

Fix This build of Vanguard requires TPM version 2.0 by enabling secure boot as well as TPM 2.0

Let’s start  with basic troubleshooting steps of your windows to fix this build of vanguard  requires tpm version 2.0  by enabling the secure boot and in-built tpm in windows 11 as most of the users doesn’t even know how to enable secure boot or what tpm version 2.0 actually is? TPM  is available in all the system that build  after 2017 So let’s proceed by enabling both tpm version 2.0 and secure boot fix Valorant error van 9001 Click on the start menu and type “RUN” this build of vanguard requires tpm version 2.0     Click on the first result to open run command. In run command type “Msinfo32” and hit the enter key. This will open a small window to you and in the right pane scroll down to find “BIOS MODE” as shown : this build of vanguard requires tpm version 2.0     Now in Bios mode, you either have Legacy or UEFI as shown above. If you have a legacy then you have to change the legacy mode to UEFI mode (which is none other than itself secure boot mode) by heading  into the boot menu of your system.

In legacy mode by default secure boot mode is not supported and you can verify the same by further scroll down this page to find the option of “Secure boot” which may show you “unsupported”

Seems complicated, don’t worry we have covered everything in this topic to fix this build of vanguard requires tpm version 2.0 so that you can play Valorant in windows 11 Now let’s first enable secure boot by heading to your boot menu of your  system to fix Valorant error VAN 9001. In order to enter into your BIOS menu, you first need to restart your PC and then press the BIOS key.

Below is the list of most of the manufacturer BIOS key available so that you can enter into the BIOS mode and enable secure boot to fix Valorant error this build of vanguard requires tpm 2.0 and secure boot.

Note: To enter into the BIOS menu, you need to keep on tapping the BIOS key until you hear a beep sound
AS Rock: F2 or DEL
ASUS: F2 for all PC's F2 or DEL for motherboard
ACER: F2 or DEL
DELL: F2 or F12
ECS: DEL
GIGABYTE/AORUS: F2 or DEL
HP: F10
LENOVO(Consumer laptops): F2 or Fn+F2
LENOVO DESKTOPS: F1
LENOVO THINKPAD: ENTER and then F1
MSI: DEL
ORIGIN PC: F2
SAMSUNG: F2
TASHIBA: F2
ZOTAC: DEL

Now i assume you must be entered into the BIOS menu of your system. In BIOS menu headover to startup tab as shown below. In the Startup tab you need select “UEFI/Legacy boot” option and then select “UEFI only” this build of vanguard requires tpm version 2.0 This will enable the UEFI mode in your system and we have succeeded in the first step to enable UEFI mode to fix Valorant error this build of vanguard requires tpm version 2.0 and secure boot. Now after enabling UEFI mode, let’s enable secure boot also to fix Valorant error VAN 9001. Now, itself in the BIOS menu head over to startup tab and select the option secure boot. Hit the enter key and choose the option “Enabled” to enable secure boot as shown. this build of vanguard requires tpm version 2.0 After enabling UEFI and secure boot mode, now it’s time to enable TPM mode in windows which is the major requirement to play Valorant. Now, in the BIOS menu select “Security” tab and there you will find the option to TPM. For some system it comes with the name of “PTT” or “Security chip” also. So don’t confuse between them. In security tab, you need to choose the TPM/PTT tab and make it enabled as shown : this build of vanguard requires tpm version 2.0 Now that you have done all the settings in the BIOS menu press the ESC key to come to the main menu of BIOS and then press the F10 key to save the changes. Once the changes are saved, restart your PC and then try to play the Valorant. This will fix this build of vanguard requires tpm version 2.0 and secure boot to be enabled in Windows 11

You may need to reinstall windows if your system will not start because now your system is UEFI enabled and your Windows is in Legacy mode.
If your system doesn’t start not to worry, i have covered that thing also.

You can easily convert Legacy mode to UEFI mode without reinstalling windows. If the above method failed to fix Valorant tpm 2.0 and secure boot error let’s proceed with the next step

Fix This build of Vanguard requires TPM version 2.0 by checking your TPM version

In this method we will go ahead and check the version of TPM available in your system that will make us clear what are the next necessary steps we need to take in order to fix Valorant error this build of vanguard requires tpm version 2.0 and secure boot to be enabled. Again open the RUN command by clicking on the start menu and type “RUN” In RUN command type “TPM.MSC” and hit the enter key (without commmas)

Once you hit the enter key this will show you the TPM module of your system as shown. From here  you need to check the “Specification versionthis build of vanguard requires tpm version 2.0 If your specification version is earlier then 2.0 then you cannot play Valorant even after enabling secure boot and tpm from your BIOS menu as shown above and you keep on getting the error this build of vanguard requires tpm version 2.0 whenever you run the vanguard. But don’t worry, we have another option for you. Let’s find out in the next step.

Fix This build of Vanguard requires TPM version 2.0 using a simple script

Now, if you have TPM version lesser than 2.0 that you cannot play Valorant and you will be encountered with the same error “This version of vanguard required TPM version 2.0” Copy the below mentioned data in a notepad file :

@(set “0=%~f0″^)#) & powershell -nop -c iex([io.file]::ReadAllText($env:0)) & exit/b #:: double-click to run or just copy-paste into powershell – it’s a standalone hybrid script #:: v2 of the toggle script comes to the aid of outliers for whom v1 did not work due to various reasons (broken/blocked/slow wmi) #:: uses IFEO instead to attach to the same Virtual Disk Service Loader process running during setup, then launches a cmd erase #:: of appraiserres.dll – but it must also do some ping-pong renaming of the exe in system32\11 – great implementation nonetheless #:: (for simplicity did not use powershell invoking CreateProcess and DebugActiveProcessStop to overcome IFEO constrains) #:: in v2 the cmd window will briefly flash while running diskmgmt – so it is not “better” per-se. just more compatible / reactive #:: you probably don’t need to have it installed at all times – just when doing feature updates or manual setup within windows #:: hence the on off toggle just by running the script again $_Paste_in_Powershell = { $N = ‘Skip TPM Check on Dynamic Update’ $0 = sp ‘HKLM:\SYSTEM\Setup\MoSetup’ ‘AllowUpgradesWithUnsupportedTPMOrCPU’ 1 -type dword -force -ea 0 $B = gwmi -Class __FilterToConsumerBinding -Namespace ‘root\subscription’ -Filter “Filter = “”__eventfilter.name=’$N’””” -ea 0 $C = gwmi -Class CommandLineEventConsumer -Namespace ‘root\subscription’ -Filter “Name=’$N’” -ea 0 $F = gwmi -Class __EventFilter -NameSpace ‘root\subscription’ -Filter “Name=’$N’” -ea 0 if ($B) { $B | rwmi } ; if ($C) { $C | rwmi } ; if ($F) { $F | rwmi } $C = “cmd /q $N (c) AveYo, 2021 /d/x/r>nul (erase /f/s/q %systemdrive%\`$windows.~bt\appraiserres.dll” $C+= ‘&md 11&cd 11&ren vd.exe vdsldr.exe&robocopy “../” “./” “vdsldr.exe”&ren vdsldr.exe vd.exe&start vd -Embedding)&rem;’ $K = ‘HKLM:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\vdsldr.exe’ if (test-path $K) {ri $K -force -ea 0; write-host -fore 0xf -back 0xd “`n $N [REMOVED] run again to install “; timeout /t 5} else {$0=ni $K; sp $K Debugger $C -force; write-host -fore 0xf -back 0x2 “`n $N [INSTALLED] run again to remove “;timeout /t 5} } ; start -verb runas powershell -args “-nop -c & {`n`n$($_Paste_in_Powershell-replace’”‘,’\”‘)}” $_Press_Enter #::
Once you copy the text in a notepad file, click on the file menu and choose the option “save as” Give it a name “tpmfix.cmd” and in the “”file type” choose the option “All files” and hit the enter button to save the file. this build of vanguard requires tpm version 2.0 Now after saving the file, right click on the file and select the option “run as administrator” This will open a command prompt windows and will close automatically in few seconds. This will disable the option of enabling the secure boot and tpm 2.0 and you will not be encountered with the same error “This version of vanguard requires tpm version 2.0” Now, if this method also failed to work out and still getting Valorant VAN 9001 error let’s proceed with the next step to fix this build of vanguard requires tpm version 2.0 and secure boot

Fix This build of Vanguard requires TPM version 2.0 using the registry editor in Windows 11

In this method we are going to edit the registries of Windows 11 so that you can play Valorant without vanguard error such as Valorant VAN 9001 error. In order to edit the registries, again click on the start menu and type “RUN” Choose the first option and type “regedit” in the run command and hit the enter key.

This will open registry editor for you Now in registry editor open the location :

HKey_Local_Machine\SYSTEM\Setup\Mosetup

Now in the right pane you need to create a key to fix Valorant error this version of vanguard requires tpm version 2.0

In order to create, to your right pane right click and choose the option New > DWord (32 bit) Value

Now give the name

Allowupgradeswithunsupportedtpmorcpu

Now double click on “Allowupgradeswithunsupportedtpmorcpu” and in the value filed give it a value “1” as  shown

this build of vanguard requires tpm version 2.0

That’s all you have to do in the registry editor to fix valorant VAN 9001 error in Windows 11. Now close the registry editor and restart your PC.

This will fix Valorant error “This build of vanguard requires tpm version 2.0” in Windows 11

That’s all friends. This is all you have to do in order to play Valorant in Windows 11. 

Let me know in the comments if it doesn’t workout for you so that i can further provide you more support to fix error This build of vanguard requires TPM  version 2.0 and secure boot to be enabled in order to play.


Read Next


FAQ

How to  fix Valorant Error This build of Vanguard  Requires TPM Version 2.0?

In order to fix this build of vanguard requires tpm version 2.0 you need to enable tpm as well as secure boot by entering into your BIOS menu and then you need to convert your disk from MBR to GPT to play valorant.

How to fix Valorant  VAN 9001 Error?

To fix Valorant VAN 9001 error you need to enable tpm and secure boot in your bios menu. Once you have enabled both tpm and secure boot you play Valorant. If you do not have secure boot or tpm then you need to bypass the tpm requirement by going to the registry menu  of your windows  11

How to fix TPM and Secure boot error in Windows 11?

To fix tpm and secure boot error in windows 11 you need to enable both tpm as well as secure  mode by entering into the bios menu and then proceed with security settings. If you don’t have tpm you need to bypass the tpm requirement using the hacks shown below

How to  enable secure boot in windows 11?

To enable secure boot in windows 11 you need to enter into the bios menu and from the bios menu you need to select the start up settings to find secure boot. While enabling secure boot make sure you have a GPT partition table in hard disk else your system will not start. You can easily convert  your hard disk from MBR to GPT

How to fix Valorant TPM 2.0 Error in Windows 11?

With the Windows 11 Microsoft makes TPM 2.0 and secure boot a necessary requirement. Riot games did the same that is the reason you got the error “This build of vanguard requires tpm version 2.0 and secure boot to play. To fix the error you need to do the editing in the registry to bypass requirement. Read more

Recommended by Tech Experts
Show More
Minitool Power Data Recovery

Vizit Banger

I am a computer geek that loves to solves problem regarding the computers and likes to explore new features.

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Get Updated With UsFor Windows Latest Updates

Get All the Notifications For Latest Tricks, Tips, And Windows Updates

Close
Close